diff src/CMakeLists.txt @ 53:a43d8cf2fa95

Various fixes and improvements. Fix windows packaging.
author Andre Heinecke <andre.heinecke@intevation.de>
date Tue, 19 Jul 2016 17:45:57 +0200
parents 36ee5dd46fd3
children 1e6e7699f0b8
line wrap: on
line diff
--- a/src/CMakeLists.txt	Tue Jul 19 17:45:10 2016 +0200
+++ b/src/CMakeLists.txt	Tue Jul 19 17:45:57 2016 +0200
@@ -41,12 +41,6 @@
 
 qt5_add_resources(APPLICATION_SRC icons/icons.qrc)
 
-add_executable(${PROJECT_NAME}
-    ${_add_executable_params}
-    ${APPLICATION_SRC}
-    ${TRANSLATION_SRC}
-)
-
 # See: https://bugreports.qt-project.org/browse/QTBUG-35918
 # extra static libs should be automatically managed but they
 # are not so we make this here explicitly neccessary.
@@ -97,6 +91,7 @@
 if (WIN32)
    get_target_property(_loc Qt5::Widgets LOCATION)
    get_filename_component(_qtpath ${_loc} PATH)
+   set (_add_executable_params WIN32)
    set(EXTRA_STATIC_LIBS
        -L${_qtpath}
        Qt5::QWindowsIntegrationPlugin
@@ -106,6 +101,12 @@
        -ladvapi32 -lshell32 -luser32 -lkernel32 -lqtfreetype -lqtharfbuzzng -lpcre16)
 endif()
 
+add_executable(${PROJECT_NAME}
+    ${_add_executable_params}
+    ${APPLICATION_SRC}
+    ${TRANSLATION_SRC}
+)
+
 target_link_libraries(${PROJECT_NAME}
     Qt5::Widgets
     Qt5::PrintSupport
This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)