diff setup.py @ 380:20fde79f8e12

Move all scripts in a common scripts directory Currently console scripts were kept in several directories. Now use a common directory for all scripts.
author Björn Ricks <bjoern.ricks@intevation.de>
date Mon, 05 Jan 2015 10:54:20 +0100
parents 51b2e575f397
children 2f9acd073dd3
line wrap: on
line diff
--- a/setup.py	Wed Mar 12 10:57:21 2014 +0100
+++ b/setup.py	Mon Jan 05 10:54:20 2015 +0100
@@ -9,15 +9,19 @@
 # For details see LICENSE coming with the source of 'getan'.
 #
 
+import glob
+import os.path
+
 from setuptools import setup, find_packages
 
-import os.path
-
 import getan
 
+cur_dir = os.path.dirname(__file__)
+scripts_dir = os.path.join(cur_dir, "scripts")
+
 
 def read(fname):
-    with open(os.path.join(os.path.dirname(__file__), fname)) as f:
+    with open(os.path.join(cur_dir, fname)) as f:
         return f.read()
 
 setup(name="getan",
@@ -27,13 +31,15 @@
       license="GPLv3+",
       long_description=read("README"),
       packages=find_packages(),
-      package_data={"": ["*.txt"], },
+      package_data={
+          "": ["*.txt"],
+      },
+      scripts=glob.glob(os.path.join(scripts_dir, "*.py")) +
+      [os.path.join(scripts_dir, "wochenbericht"),
+       os.path.join(scripts_dir, "convert-projects")],
       entry_points={"console_scripts":
                     ["getan=getan.main:main",
                      "getan-classic=getan.classic.getan:main",
-                     "zeiterfassung=getan.contrib.zeiterfassung:main",
-                     "getan-eval=getan.contrib.getan-eval:main",
-                     "zeitsort=getan.contrib.zeitsort:main",
                      ]},
       classifiers=[
           "Topic :: Utilities",
@@ -43,5 +49,5 @@
           "License :: OSI Approved :: GNU General Public License (GPL)",
           "Operating System :: POSIX",
           "Programming Language :: Python",
-      ]
+      ],
       )
This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)