diff debian/rules @ 120:efff8b9e7046

Add debian package description It may not be complete yet. Also classic getan should be installed in a seperate package.
author Björn Ricks <bjoern.ricks@intevation.de>
date Mon, 12 Dec 2011 09:58:17 +0100
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/debian/rules	Mon Dec 12 09:58:17 2011 +0100
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+%:
+	dh $@
+
+PYVERS=$(shell pyversions -vs)
+
+override_dh_auto_install: $(PYVERS:%=install-python%)
+	dh_auto_install
+
+install-python%:
+	python setup.py install --root $(CURDIR)/debian/getan --install-layout=deb
+
+override_dh_install:
+	dh_install
This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)