diff setup.py @ 417:d6d9d319bd2e

Prepares for PyPi publication.
author Bernhard Reiter <bernhard@intevation.de>
date Wed, 03 May 2017 16:29:24 +0200
parents 69ef6f89e930
children 17e302a0cd9a
line wrap: on
line diff
--- a/setup.py	Wed May 03 14:06:35 2017 +0200
+++ b/setup.py	Wed May 03 16:29:24 2017 +0200
@@ -31,8 +31,12 @@
 
 setup(name="getan",
       version=getan.__version__,
-      description="getan - A worklog like tool",
-      url="https://scm.wald.intevation.org/hg/getan/",
+      description="getan - terminal based time-tracking "
+                  "and reporting; comparable to 'worklog'",
+      url="https://getan.wald.intevation.org/",
+      download_url="https://scm.wald.intevation.org/hg/getan/",
+      maintainer="Bernhard E. Reiter",
+      maintainer_email="bernhard.reiter@intevation.de",
       license="GPLv3+",
       long_description=read("README"),
       packages=find_packages(),
@@ -40,6 +44,10 @@
           "": ["*.txt"],
           "getan": ["templates/*"],
       },
+      install_requires=[
+          'jinja2',
+          'urwid>=1.1.2'
+      ],
       scripts=glob.glob(os.path.join(scripts_dir, "*.py")) +
       [os.path.join(scripts_dir, "wochenbericht"),
        os.path.join(scripts_dir, "convert-projects")],
@@ -48,12 +56,14 @@
                      "getan-classic=getan.classic.getan:main",
                      ]},
       classifiers=[
+          "Development Status :: 5 - Production/Stable",
           "Topic :: Utilities",
           "Environment :: Console",
           "Intended Audience :: Developers",
           "Intended Audience :: End Users/Desktop",
-          "License :: OSI Approved :: GNU General Public License (GPL)",
+          "License :: OSI Approved :: "
+              "GNU General Public License v3 or later (GPLv3+)",
           "Operating System :: POSIX",
-          "Programming Language :: Python",
+          "Programming Language :: Python :: 2"
       ],
       )
This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)