diff pom.xml @ 435:2b58a86ca06f

Updated dependencies and LoggerFactory. Using log4j2 now.
author Raimund Renkert <raimund.renkert@intevation.de>
date Fri, 06 Feb 2015 13:35:12 +0100
parents 5fe37b00ed41
children 5011173fd340
line wrap: on
line diff
--- a/pom.xml	Fri Feb 06 12:24:23 2015 +0100
+++ b/pom.xml	Fri Feb 06 13:35:12 2015 +0100
@@ -46,11 +46,11 @@
             <artifactId>cdi-api</artifactId>
             <scope>provided</scope>
         </dependency>
-        <dependency>
+        <!-- dependency>
             <groupId>javax.ws.rs</groupId>
             <artifactId>jsr311-api</artifactId>
             <version>1.1.1</version>
-        </dependency>
+        </dependency-->
         <dependency>
             <groupId>org.jboss.spec.javax.ejb</groupId>
             <artifactId>jboss-ejb-api_3.2_spec</artifactId>
@@ -98,6 +98,28 @@
             <version>4.3</version>
         </dependency>
 
+        <!-- Logging -->
+        <dependency>
+            <groupId>org.apache.logging.log4j</groupId>
+            <artifactId>log4j-core</artifactId>
+            <version>2.1</version>
+        </dependency>
+        <dependency>
+            <groupId>com.fasterxml.jackson.core</groupId>
+            <artifactId>jackson-core</artifactId>
+            <version>2.4.2</version>
+        </dependency>
+        <dependency>
+            <groupId>com.fasterxml.jackson.core</groupId>
+            <artifactId>jackson-databind</artifactId>
+            <version>2.4.2</version>
+        </dependency> 
+        <dependency>
+            <groupId>com.fasterxml.jackson.core</groupId>
+            <artifactId>jackson-annotations</artifactId>
+            <version>2.4.2</version>
+        </dependency>
+
         <!-- Arquillian/Testing -->
         <dependency>
         <groupId>junit</groupId>
This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)