diff doc/CMakeLists.txt @ 66:098a10fc2e83 0.9.2

Add doxygen files and improve doxygen comments
author Andre Heinecke <andre.heinecke@intevation.de>
date Thu, 21 May 2015 15:21:47 +0200
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/doc/CMakeLists.txt	Thu May 21 15:21:47 2015 +0200
@@ -0,0 +1,24 @@
+# Copyright (C) 2014 by Bundesamt für Sicherheit in der Informationstechnik
+# Software engineering by Intevation GmbH
+#
+# This file is Free Software under the GNU GPL (v>=2)
+# and comes with ABSOLUTELY NO WARRANTY!
+# See LICENSE.txt for details.
+
+include (FindDoxygen)
+
+set_directory_properties (PROPERTIES CLEAN_NO_CUSTOM true)
+set_directory_properties (PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES ".built-html")
+
+if (NOT DOXYGEN_EXECUTABLE)
+    message (STATUS "WARNING: Doxygen is required to build the docs.")
+else()
+    add_custom_target (doc COMMENT "Building documentation..."
+    DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile ${CMAKE_CURRENT_BINARY_DIR}/.built-html)
+endif()
+
+add_custom_command (OUTPUT .built-html
+    COMMAND sh
+    ARGS -c \"${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile && touch ${CMAKE_CURRENT_BINARY_DIR}/.built-html\;\"
+    ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
+)
This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)