diff cinst/CMakeLists.txt @ 37:00aa5fa3c2fb

Build System maintainance. Correct integration of Polarssl. Make profiling an option, fix static_check target
author Andre Heinecke <aheinecke@intevation.de>
date Fri, 14 Mar 2014 09:01:19 +0000
parents 92108a2120f1
children 3f6378647371
line wrap: on
line diff
--- a/cinst/CMakeLists.txt	Fri Mar 14 08:59:06 2014 +0100
+++ b/cinst/CMakeLists.txt	Fri Mar 14 09:01:19 2014 +0000
@@ -1,8 +1,18 @@
 set(CMAKE_AUTOMOC OFF)
 
+include_directories(${POLARSSL_INCLUDE_DIR})
+
 set(CINST_SOURCES
     ${CMAKE_SOURCE_DIR}/cinst/main.c
     ${CMAKE_SOURCE_DIR}/common/listutil.c
 )
 
+set(MOZILLA_SOURCES
+    ${CMAKE_SOURCE_DIR}/cinst/mozilla.c
+)
+
 add_executable(cinst ${CINST_SOURCES})
+
+target_link_libraries(cinst
+   ${PROFILING_LIBS}
+   ${POLARSSL_LIBRARIES})

http://wald.intevation.org/projects/trustbridge/