diff cinst/CMakeLists.txt @ 1022:55a2ace0937d

Merged.
author Emanuel Schuetze <emanuel@intevation.de>
date Wed, 03 Sep 2014 09:55:13 +0200
parents 4f999c7821ce
children fc4e1fe4e4d4
line wrap: on
line diff
--- a/cinst/CMakeLists.txt	Tue Sep 02 15:43:58 2014 +0200
+++ b/cinst/CMakeLists.txt	Wed Sep 03 09:55:13 2014 +0200
@@ -30,6 +30,19 @@
    ${WIN_EXTRA_LIBS})
 
 install(TARGETS cinst DESTINATION bin)
+if (WIN32)
+   add_custom_command(
+      TARGET cinst
+      POST_BUILD
+      COMMAND ${CMAKE_STRIP} cinst.exe
+   )
+else()
+   add_custom_command(
+      TARGET cinst
+      POST_BUILD
+      COMMAND strip cinst
+   )
+endif()
 
 # ----------------------------------------------------------------------
 # Mozilla nss store specific certificate installer:
@@ -48,6 +61,20 @@
       ${PROFILING_LIBS})
    set_target_properties(mozilla PROPERTIES COMPILE_FLAGS "-std=c99")
    install(TARGETS mozilla DESTINATION bin)
+
+   if (WIN32)
+      add_custom_command(
+         TARGET mozilla
+         POST_BUILD
+         COMMAND ${CMAKE_STRIP} mozilla.exe
+      )
+   else()
+      add_custom_command(
+         TARGET mozilla
+         POST_BUILD
+         COMMAND strip mozilla
+      )
+   endif()
 else()
    message(STATUS "WARNING: Could not find nss. Mozilla cert installer will not be build!")
 endif()

http://wald.intevation.org/projects/trustbridge/