diff ui/CMakeLists.txt @ 1022:55a2ace0937d

Merged.
author Emanuel Schuetze <emanuel@intevation.de>
date Wed, 03 Sep 2014 09:55:13 +0200
parents 4f999c7821ce
children 126e5ce4d1d1
line wrap: on
line diff
--- a/ui/CMakeLists.txt	Tue Sep 02 15:43:58 2014 +0200
+++ b/ui/CMakeLists.txt	Wed Sep 03 09:55:13 2014 +0200
@@ -223,3 +223,28 @@
   configure_file(trustbridge-tray-starter.sh trustbridge-tray-starter.sh COPYONLY)
   install(FILES trustbridge-tray-starter.sh DESTINATION bin)
 endif()
+
+# Strip the binaries
+if (WIN32)
+   add_custom_command(
+      TARGET trustbridge
+      POST_BUILD
+      COMMAND ${CMAKE_STRIP} trustbridge.exe
+   )
+   add_custom_command(
+      TARGET trustbridge-admin
+      POST_BUILD
+      COMMAND ${CMAKE_STRIP} trustbridge-admin.exe
+   )
+else()
+   add_custom_command(
+      TARGET trustbridge
+      POST_BUILD
+      COMMAND strip trustbridge
+   )
+   add_custom_command(
+      TARGET trustbridge-admin
+      POST_BUILD
+      COMMAND ${CMAKE_STRIP} trustbridge-admin
+   )
+endif()

http://wald.intevation.org/projects/trustbridge/