diff CMakeLists.txt @ 557:5cd525fc91de

Add lcov target to generate coverage report
author Andre Heinecke <aheinecke@intevation.de>
date Thu, 22 May 2014 10:19:27 +0000
parents 4f972b1f4996
children 7dfa4555fb89
line wrap: on
line diff
--- a/CMakeLists.txt	Thu May 22 08:59:13 2014 +0000
+++ b/CMakeLists.txt	Thu May 22 10:19:27 2014 +0000
@@ -118,3 +118,10 @@
 
 set(NSS_BASE_DIR "${NSS_BASE_DIR}/..")
 configure_file (packaging/tmp-createpackage.sh.in packaging/tmp-createpackage.sh)
+
+if (ENABLE_PROFILING)
+   configure_file (make-coverage.sh.in make-coverage.sh)
+   add_custom_target(lcov COMMENT "Lcov coverage report" VERBATIM COMMAND /bin/bash
+      ${CMAKE_CURRENT_BINARY_DIR}/make-coverage.sh
+   )
+endif()

http://wald.intevation.org/projects/trustbridge/