diff CMakeLists.txt @ 1220:60927efa48cc

(issue128) Add manifest for the correct execution level.
author Andre Heinecke <andre.heinecke@intevation.de>
date Wed, 24 Sep 2014 11:42:29 +0200
parents 69f7d302cdb9
children 3cd8dd706aaa
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Sep 24 11:35:20 2014 +0200
+++ b/CMakeLists.txt	Wed Sep 24 11:42:29 2014 +0200
@@ -134,6 +134,12 @@
 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
 
+# Cmake does not correctly identify gcc windres when cross compiling
+# making this line neccessary to set the correct flags for it.
+# See: http://public.kitware.com/Bug/view.php?id=11773
+SET(CMAKE_RC_COMPILE_OBJECT
+      "<CMAKE_RC_COMPILER> <FLAGS> <DEFINES> -Ocoff <SOURCE> <OBJECT>")
+
 add_subdirectory(common)
 
 add_subdirectory(cinst)

http://wald.intevation.org/projects/trustbridge/