diff cinst/CMakeLists.txt @ 224:689b94dd89a9

Wrote FindNSS to build against nss without pkg-config support (Windows).
author Sascha Wilde <wilde@intevation.de>
date Thu, 27 Mar 2014 17:00:01 +0100
parents d29997e09177
children 809eaca3898c
line wrap: on
line diff
--- a/cinst/CMakeLists.txt	Thu Mar 27 12:46:46 2014 +0100
+++ b/cinst/CMakeLists.txt	Thu Mar 27 17:00:01 2014 +0100
@@ -25,12 +25,10 @@
 # ----------------------------------------------------------------------
 # Mozilla nss store specific certificate installer:
 
-include(FindPkgConfig)
-# FIXME: maybe a minimal version would be wise...
-pkg_check_modules (NSS  nss)
-include_directories(${NSS_INCLUDE_DIRS})
+find_package(NSS)
 
 if(NSS_FOUND)
+  include_directories(${NSS_INCLUDE_DIRS})
   set(MOZILLA_SOURCES
     ${CMAKE_CURRENT_SOURCE_DIR}/mozilla.c
     )

http://wald.intevation.org/projects/trustbridge/