diff CMakeLists.txt @ 1387:c64b6c56ce96 0.9.8

(issue95) Change keys for release build. Fix release build usage.
author Andre Heinecke <andre.heinecke@intevation.de>
date Thu, 15 Jan 2015 16:46:36 +0100
parents 8897c90b8166
children
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Jan 15 16:14:35 2015 +0100
+++ b/CMakeLists.txt	Thu Jan 15 16:46:36 2015 +0100
@@ -13,7 +13,7 @@
 option(USE_CURL "Use libcurl to download updates and certificate lists." ON)
 option(USE_CLANG "Use clang to compile trustbridge." OFF)
 
-set(DOWNLOAD_SERVER "https://tb-devel.intevation.de:443" CACHE STRING "Used as download server" )
+set(DOWNLOAD_SERVER "https://updates.trustbridge.de:443" CACHE STRING "Used as download server" )
 set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/")
 
 #Old qtmain linking behavior to be compatible with cmake versions < 2.8.11
@@ -22,6 +22,12 @@
   cmake_policy(SET CMP0020 OLD)
 endif()
 
+if (DO_RELEASE_BUILD)
+   message (STATUS "Building in release mode")
+   # Release build should automatically use tag build
+   add_definitions(-DIS_TAG_BUILD)
+endif()
+
 if (USE_CLANG)
    message (STATUS "Using clang options to build trustbridge.")
    # This is a bit of a hack but necessary on Ubuntu 14.4
@@ -74,7 +80,6 @@
       set (CMAKE_BUILD_TYPE RELEASE)
    endif (NOT CMAKE_BUILD_TYPE)
    add_definitions (-DRELEASE_BUILD)
-   set(USE_REAL_RESOURCES ON)
 else()
 # Default to debug build
    if (NOT CMAKE_BUILD_TYPE)
@@ -84,10 +89,6 @@
    endif (NOT CMAKE_BUILD_TYPE)
 endif()
 
-if(USE_REAL_RESOURCES)
-   add_definitions (-DUSE_REAL_RESOURCES)
-endif()
-
 if (NOT USE_CLANG)
 # Warn level to be used for privileged parts
    set(WARN_HARDENING_FLAGS " -Wextra -Wconversion -Wformat-security")

http://wald.intevation.org/projects/trustbridge/