diff doc/apidoc/CMakeLists.txt @ 1184:cf1fdb254c41

Moved help pages from 'manuals' to 'doc/help'. Updated .hgignore.
author Emanuel Schuetze <emanuel@intevation.de>
date Mon, 22 Sep 2014 13:02:11 +0200
parents doc/CMakeLists.txt@35d6b371ba63
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/doc/apidoc/CMakeLists.txt	Mon Sep 22 13:02:11 2014 +0200
@@ -0,0 +1,24 @@
+# Copyright (C) 2014 by Bundesamt für Sicherheit in der Informationstechnik
+# Software engineering by Intevation GmbH
+#
+# This file is Free Software under the GNU GPL (v>=2)
+# and comes with ABSOLUTELY NO WARRANTY!
+# See LICENSE.txt for details.
+
+include (FindDoxygen)
+
+set_directory_properties (PROPERTIES CLEAN_NO_CUSTOM true)
+set_directory_properties (PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES ".built-html")
+
+if (NOT DOXYGEN_EXECUTABLE)
+    message (STATUS "WARNING: Doxygen is required to build the docs.")
+else()
+    add_custom_target (doc COMMENT "Building documentation..."
+    DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile ${CMAKE_CURRENT_BINARY_DIR}/.built-html)
+endif()
+
+add_custom_command (OUTPUT .built-html
+    COMMAND sh
+    ARGS -c \"${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile && touch ${CMAKE_CURRENT_BINARY_DIR}/.built-html\;\"
+    ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
+)

http://wald.intevation.org/projects/trustbridge/