diff ui/tests/CMakeLists.txt @ 978:d92b1594e974

Merged.
author Emanuel Schuetze <emanuel@intevation.de>
date Fri, 29 Aug 2014 13:10:11 +0200
parents 9494d4ee1d4e
children 7d08fd354bff
line wrap: on
line diff
--- a/ui/tests/CMakeLists.txt	Fri Aug 29 13:09:40 2014 +0200
+++ b/ui/tests/CMakeLists.txt	Fri Aug 29 13:10:11 2014 +0200
@@ -48,7 +48,6 @@
      Qt5::Test Qt5::Widgets
      trustbridge_common
      ${CURL_LIBRARIES}
-     z
      ${POLARSSL_LIBRARIES}
      ${EXTRA_STATIC_LIBS})
 endmacro()
@@ -78,6 +77,11 @@
 if (WIN32)
    add_custom_test(windowsstoretest.cpp "${CMAKE_SOURCE_DIR}/cinst/windowsstore.c")
 
+   if (NOT "${CMAKE_STRIP}")
+      message(STATUS "WARNING CMAKE_STRIP not set. Please set this in your toolchain file. Falling back to: i686-w64-mingw32-strip")
+      set (CMAKE_STRIP "i686-w64-mingw32-strip")
+   endif()
+
    if (OSSLSIGNCODE_EXECUTABLE)
       add_custom_test (binverifytest.cpp "")
       add_custom_command(

http://wald.intevation.org/projects/trustbridge/