diff doc/CMakeLists.txt @ 24:de67047ca229

Add documentation generation
author Andre Heinecke <aheinecke@intevation.de>
date Fri, 21 Feb 2014 15:12:24 +0000
parents
children 35d6b371ba63
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/doc/CMakeLists.txt	Fri Feb 21 15:12:24 2014 +0000
@@ -0,0 +1,17 @@
+include (FindDoxygen)
+
+set_directory_properties (PROPERTIES CLEAN_NO_CUSTOM true)
+set_directory_properties (PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES ".built-html")
+
+if (NOT DOXYGEN_EXECUTABLE)
+    message (STATUS "WARNING: Doxygen is required to build the docs.")
+else()
+    add_custom_target (doc COMMENT "Building documentation..."
+    DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile ${CMAKE_CURRENT_BINARY_DIR}/.built-html)
+endif()
+
+add_custom_command (OUTPUT .built-html
+    COMMAND sh
+    ARGS -c \"${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile && touch ${CMAKE_CURRENT_BINARY_DIR}/.built-html\;\"
+    ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
+)

http://wald.intevation.org/projects/trustbridge/