diff ui/tests/CMakeLists.txt @ 220:e6c5c70a67b0

Add test for windowsstores
author Andre Heinecke <andre.heinecke@intevation.de>
date Wed, 26 Mar 2014 20:21:55 +0100
parents 6c3a089d3265
children c05e126b0b9e
line wrap: on
line diff
--- a/ui/tests/CMakeLists.txt	Wed Mar 26 20:16:50 2014 +0100
+++ b/ui/tests/CMakeLists.txt	Wed Mar 26 20:21:55 2014 +0100
@@ -15,7 +15,10 @@
 macro(add_m13_test _source _additional_sources)
   set(_test ${_source})
   get_filename_component(_name ${_source} NAME_WE)
-  add_executable(${_name} ${_test} ${_additional_sources})
+  set(_test_sources_with_resources ${_test} ${_additional_sources})
+  qt5_add_resources(_test_sources_with_resources
+     ${CMAKE_CURRENT_SOURCE_DIR}/data/testdata.qrc)
+  add_executable(${_name} ${_test_sources_with_resources})
   add_test(m13-${_name} ${_name})
   target_link_libraries(${_name} Qt5::Test Qt5::Widgets
      m13_common
@@ -39,5 +42,9 @@
 add_m13_test(cinstprocesstest.cpp "${CERTIFICATELIST_SOURCES}")
 add_m13_test(commontest.cpp "")
 
+if (WIN32)
+   add_m13_test(windowsstoretest.cpp "${CERTIFICATELIST_SOURCES};${CMAKE_SOURCE_DIR}/cinst/windowsstore.c")
+endif (WIN32)
+
 #add_m13_test(${CMAKE_SOURCE_DIR}/ui/main.cpp "${M13UI_SOURCES}")
 

http://wald.intevation.org/projects/trustbridge/