diff ui/CMakeLists.txt @ 954:eaea1504f282

(issue41) Add curl staticlib definition This is neccessary to avoid dllimport declarations on windows.
author Andre Heinecke <andre.heinecke@intevation.de>
date Wed, 27 Aug 2014 16:29:55 +0200
parents 0abacb0fd564
children 0f7aeb12e5e9
line wrap: on
line diff
--- a/ui/CMakeLists.txt	Wed Aug 27 16:29:16 2014 +0200
+++ b/ui/CMakeLists.txt	Wed Aug 27 16:29:55 2014 +0200
@@ -28,7 +28,7 @@
 
 if (${CURL_FOUND} AND ${USE_CURL})
    set(UICOMMON_SOURCES ${UICOMMON_SOURCES} ${CMAKE_CURRENT_SOURCE_DIR}/sslconnection_curl.cpp)
-   add_definitions(-DUSE_CURL)
+   add_definitions(-DUSE_CURL -DCURL_STATICLIB)
 elseif (${USE_CURL})
    MESSAGE(FATAL_ERROR "libcurl not found but usage of curl is requested.")
 endif()

http://wald.intevation.org/projects/trustbridge/