diff ui/CMakeLists.txt @ 949:0abacb0fd564

Document and use minimized qt and document curl build for windows
author Andre Heinecke <andre.heinecke@intevation.de>
date Wed, 27 Aug 2014 10:40:41 +0200
parents 3baee3445502
children eaea1504f282
line wrap: on
line diff
--- a/ui/CMakeLists.txt	Wed Aug 27 10:40:06 2014 +0200
+++ b/ui/CMakeLists.txt	Wed Aug 27 10:40:41 2014 +0200
@@ -101,10 +101,10 @@
    get_filename_component(_qtpath ${_loc} PATH)
    set(WINDOWS_EXTRA_LIBS
         -L${_qtpath}
-        -lwinspool -lshlwapi -lfreetype -lbz2 -lpng16
+        -lwinspool -lshlwapi
         -lQt5PlatformSupport -lQt5Gui -lcomdlg32 -loleaut32 -limm32 -lwinmm
-        -lglu32 -lopengl32 -lgdi32 -ljpeg -lpng -lQt5Core -lole32 -lmstask -luuid -lws2_32
-        -ladvapi32 -lshell32 -luser32 -lkernel32 -lz -lsicuin -lsicuuc -lsicudt -lpcre16)
+        -lglu32 -lopengl32 -lgdi32 -lQt5Core -lole32 -lmstask -luuid -lws2_32
+        -ladvapi32 -lshell32 -luser32 -lkernel32 -lpcre16)
 
    set(EXTRA_STATIC_LIBS Qt5::QWindowsIntegrationPlugin ${WINDOWS_EXTRA_LIBS} -lwinhttp -lcrypt32)
 

http://wald.intevation.org/projects/trustbridge/