diff cinst/CMakeLists.txt @ 1288:265583011f24

(issue123) Add possibility to open native certificate dialog This is currently only implemented for windows.
author Andre Heinecke <andre.heinecke@intevation.de>
date Mon, 29 Sep 2014 13:12:58 +0200
parents 60927efa48cc
children
line wrap: on
line diff
--- a/cinst/CMakeLists.txt	Mon Sep 29 13:02:41 2014 +0200
+++ b/cinst/CMakeLists.txt	Mon Sep 29 13:12:58 2014 +0200
@@ -30,6 +30,7 @@
 
 if (WIN32)
    set(WIN_EXTRA_LIBS -lcrypt32 -luserenv -lshell32)
+   set(WIN_EXTRA_LIBS_NSS -lcrypt32)
 endif(WIN32)
 
 target_link_libraries(trustbridge-certificate-installer
@@ -87,7 +88,8 @@
       trustbridge_common
       ${POLARSSL_LIBRARIES}
       ${NSS_LIBRARIES}
-      ${PROFILING_LIBS})
+      ${PROFILING_LIBS}
+      ${WIN_EXTRA_LIBS_NSS})
    set_target_properties(trustbridge-nss-installer PROPERTIES COMPILE_FLAGS "-std=c99")
    install(TARGETS trustbridge-nss-installer DESTINATION bin)
 

http://wald.intevation.org/projects/trustbridge/