diff ui/tests/CMakeLists.txt @ 560:3af16cbc961d

Move UI code into librarys to speed up build of unit tests
author Andre Heinecke <aheinecke@intevation.de>
date Thu, 22 May 2014 10:57:05 +0000
parents dd8a295d5b4d
children aee3eb10bbba
line wrap: on
line diff
--- a/ui/tests/CMakeLists.txt	Thu May 22 10:20:45 2014 +0000
+++ b/ui/tests/CMakeLists.txt	Thu May 22 10:57:05 2014 +0000
@@ -32,6 +32,8 @@
   add_executable(${_name} ${_test_sources_with_resources})
   add_test(tb-${_name} ${_name})
   target_link_libraries(${_name}
+     tbadminlib
+     tblib
      ui_common
      Qt5::Test Qt5::Widgets
      trustbridge_common
@@ -42,7 +44,7 @@
 # Add the current source dir to the definition
 # so that it can be used in file names in the tests.
 add_definitions(-DSOURCE_DIR="${CMAKE_CURRENT_SOURCE_DIR}")
-add_custom_test(certlistparsertest.cpp "${CERTIFICATELIST_SOURCES}")
+add_custom_test(certlistparsertest.cpp "")
 
 # Downloader
 if (HIAWATHA_EXECUTABLE)
@@ -55,8 +57,8 @@
 add_dependencies(cinstprocesstest cinst)
 add_custom_test(commontest.cpp "")
 
-add_custom_test(createcertlisttest.cpp "${CMAKE_SOURCE_DIR}/ui/createcertlistdialog.cpp")
-add_custom_test(mainwindowtest.cpp "${TRUSTBRIDGE_SOURCES}")
+add_custom_test(createcertlisttest.cpp "")
+add_custom_test(mainwindowtest.cpp "")
 
 if (WIN32)
    add_custom_test(windowsstoretest.cpp "${CMAKE_SOURCE_DIR}/cinst/windowsstore.c")

http://wald.intevation.org/projects/trustbridge/