diff ui/tests/CMakeLists.txt @ 48:3f8c2d46ded6

Add test for no connection handling
author Andre Heinecke <aheinecke@intevation.de>
date Mon, 17 Mar 2014 11:20:37 +0000
parents c6125d73faf4
children 8ffbb48528ae
line wrap: on
line diff
--- a/ui/tests/CMakeLists.txt	Mon Mar 17 11:03:17 2014 +0000
+++ b/ui/tests/CMakeLists.txt	Mon Mar 17 11:20:37 2014 +0000
@@ -25,6 +25,11 @@
 # so that it can be used in file names in the tests.
 add_definitions(-DSOURCE_DIR="${CMAKE_CURRENT_SOURCE_DIR}")
 add_m13_test(certlistparsertest.cpp "${CERTIFICATELIST_SOURCES}")
-add_m13_test(downloadertest.cpp "${DOWNLOADER_SOURCES}")
+
+# Downloader
+set(DOWNLOADER_SOURCES_WITH_RESOURCES ${DOWNLOADER_SOURCES})
+qt5_add_resources(DOWNLOADER_SOURCES_WITH_RESOURCES ${M13UI_RESOURCES})
+add_m13_test(downloadertest.cpp "${DOWNLOADER_SOURCES_WITH_RESOURCES}")
+
 #add_m13_test(${CMAKE_SOURCE_DIR}/ui/main.cpp "${M13UI_SOURCES}")
 

http://wald.intevation.org/projects/trustbridge/