diff cinst/CMakeLists.txt @ 1220:60927efa48cc

(issue128) Add manifest for the correct execution level.
author Andre Heinecke <andre.heinecke@intevation.de>
date Wed, 24 Sep 2014 11:42:29 +0200
parents e978f655be34
children 265583011f24
line wrap: on
line diff
--- a/cinst/CMakeLists.txt	Wed Sep 24 11:35:20 2014 +0200
+++ b/cinst/CMakeLists.txt	Wed Sep 24 11:42:29 2014 +0200
@@ -17,6 +17,15 @@
     ${CMAKE_CURRENT_SOURCE_DIR}/nssstore_win.c
     ${CMAKE_CURRENT_SOURCE_DIR}/certificate-installer.c
 )
+if (WIN32)
+   # Add asInvoker manifest to avoid windows heuristics
+   # that want to always run an -installer with admin rights.
+    set(trustbridge-certificate-installer_SOURCES
+       ${trustbridge-certificate-installer_SOURCES}
+       ${CMAKE_CURRENT_SOURCE_DIR}/asInvoker.rc)
+endif()
+
+
 add_executable(trustbridge-certificate-installer ${trustbridge-certificate-installer_SOURCES})
 
 if (WIN32)
@@ -62,6 +71,15 @@
  ${CMAKE_CURRENT_SOURCE_DIR}/nss-installer.c
  )
 
+if (WIN32)
+   # Add asInvoker manifest to avoid windows heuristics
+   # that want to always run an -installer with admin rights.
+    set(trustbridge-nss-installer_SOURCES
+       ${trustbridge-nss-installer_SOURCES}
+       ${CMAKE_CURRENT_SOURCE_DIR}/asInvoker.rc)
+endif()
+
+
 if(WIN32 OR NSS_FOUND)
    include_directories(${NSS_INCLUDE_DIRS})
    add_executable(trustbridge-nss-installer ${trustbridge-nss-installer_SOURCES})

http://wald.intevation.org/projects/trustbridge/