diff cinst/CMakeLists.txt @ 834:8081ed84589d

Use static nss from subrepository on windows
author Andre Heinecke <andre.heinecke@intevation.de>
date Mon, 28 Jul 2014 13:03:45 +0200
parents ac9e95ef6966
children 4f999c7821ce
line wrap: on
line diff
--- a/cinst/CMakeLists.txt	Mon Jul 28 13:03:00 2014 +0200
+++ b/cinst/CMakeLists.txt	Mon Jul 28 13:03:45 2014 +0200
@@ -33,21 +33,21 @@
 
 # ----------------------------------------------------------------------
 # Mozilla nss store specific certificate installer:
+set(MOZILLA_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/nss-secitemlist.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/mozilla.c
+ )
 
-if(NSS_FOUND)
-  include_directories(${NSS_INCLUDE_DIRS})
-  set(MOZILLA_SOURCES
-    ${CMAKE_CURRENT_SOURCE_DIR}/nss-secitemlist.c
-    ${CMAKE_CURRENT_SOURCE_DIR}/mozilla.c
-    )
-  add_executable(mozilla ${MOZILLA_SOURCES})
-  target_link_libraries(mozilla
-   trustbridge_common
-   ${POLARSSL_LIBRARIES}
-   ${NSS_LIBRARIES}
-   ${PROFILING_LIBS})
- set_target_properties(mozilla PROPERTIES COMPILE_FLAGS "-std=c99")
- install(TARGETS mozilla DESTINATION bin)
+if(WIN32 OR NSS_FOUND)
+   include_directories(${NSS_INCLUDE_DIRS})
+   add_executable(mozilla ${MOZILLA_SOURCES})
+   target_link_libraries(mozilla
+      trustbridge_common
+      ${POLARSSL_LIBRARIES}
+      ${NSS_LIBRARIES}
+      ${PROFILING_LIBS})
+   set_target_properties(mozilla PROPERTIES COMPILE_FLAGS "-std=c99")
+   install(TARGETS mozilla DESTINATION bin)
 else()
    message(STATUS "WARNING: Could not find nss. Mozilla cert installer will not be build!")
 endif()

http://wald.intevation.org/projects/trustbridge/