diff ui/CMakeLists.txt @ 602:854248d81ba4

Fully switch to unicode for windows. This will be needed sooner or later and it makes sense to have it unified now.
author Andre Heinecke <andre.heinecke@intevation.de>
date Tue, 17 Jun 2014 17:25:12 +0200
parents 9cdc14373a5d
children cfef809b890d
line wrap: on
line diff
--- a/ui/CMakeLists.txt	Mon Jun 16 14:58:02 2014 +0200
+++ b/ui/CMakeLists.txt	Tue Jun 17 17:25:12 2014 +0200
@@ -94,6 +94,8 @@
         -ladvapi32 -lshell32 -luser32 -lkernel32 -lz -lsicuin -lsicuuc -lsicudt -lpcre16)
 
    set(EXTRA_STATIC_LIBS Qt5::QWindowsIntegrationPlugin ${WINDOWS_EXTRA_LIBS} -lwinhttp -lcrypt32)
+
+   add_definitions(-DUNICODE)
 endif()
 
 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS}")

http://wald.intevation.org/projects/trustbridge/