diff ui/CMakeLists.txt @ 1331:8897c90b8166

(issue108) Remove generate_cppcheck and cppcheck target This did not work correctly. It is better just to manually execute cppcheck on the files as it gives you more control over the options.
author Andre Heinecke <andre.heinecke@intevation.de>
date Wed, 15 Oct 2014 13:24:59 +0200
parents 60927efa48cc
children c64b6c56ce96
line wrap: on
line diff
--- a/ui/CMakeLists.txt	Wed Oct 15 13:19:05 2014 +0200
+++ b/ui/CMakeLists.txt	Wed Oct 15 13:24:59 2014 +0200
@@ -112,9 +112,6 @@
 
 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS}")
 
-generate_cppcheck(SOURCES ${CINST_SOURCES} ${TRUSTBRIDGE_SOURCES} TARGET_NAME custom_cppcheck)
-add_dependencies(static_check custom_cppcheck)
-
 # Adding resources here in an extra variable to enable reuse of
 # TRUSTBRIDGE_SOURCES in the test subdirectory.
 set(TRUSTBRIDGE_MAIN_WITH_RESOURCES ${CMAKE_CURRENT_SOURCE_DIR}/main.cpp

http://wald.intevation.org/projects/trustbridge/