diff ui/CMakeLists.txt @ 827:8de162b91a22

(Issue49) Create a Scheduled daily task to run trustbridge
author Andre Heinecke <andre.heinecke@intevation.de>
date Wed, 23 Jul 2014 19:47:59 +0200
parents 1e18d4c1932a
children 57b32e354e86
line wrap: on
line diff
--- a/ui/CMakeLists.txt	Mon Jul 21 18:53:13 2014 +0200
+++ b/ui/CMakeLists.txt	Wed Jul 23 19:47:59 2014 +0200
@@ -40,6 +40,7 @@
     ${CMAKE_CURRENT_SOURCE_DIR}/processhelp_linux.cpp
     ${CMAKE_CURRENT_SOURCE_DIR}/processwaitdialog.cpp
     ${CMAKE_CURRENT_SOURCE_DIR}/textoverlaybutton.cpp
+    ${CMAKE_CURRENT_SOURCE_DIR}/taskscheduler.cpp
     ${CERTIFICATELIST_SOURCES}
     ${DOWNLOADER_SOURCES}
 )
@@ -94,8 +95,9 @@
    set(WINDOWS_EXTRA_LIBS
         -L${_qtpath}
         -lwinspool -lshlwapi -lfreetype -lbz2 -lpng16
-        -lQt5PlatformSupport -lQt5Gui -lcomdlg32 -loleaut32 -limm32 -lwinmm
-        -lglu32 -lopengl32 -lgdi32 -ljpeg -lpng -lQt5Core -lole32 -luuid -lws2_32
+        -lQt5PlatformSupport -lQt5Gui -lcomdlg32 -loleaut32 -limm32
+        -lharfbuzz -lglib-2.0 -lintl -liconv -lwinmm
+        -lglu32 -lopengl32 -lgdi32 -ljpeg -lpng -lQt5Core -lole32 -lmstask -luuid -lws2_32
         -ladvapi32 -lshell32 -luser32 -lkernel32 -lz -lsicuin -lsicuuc -lsicudt -lpcre16)
 
    set(EXTRA_STATIC_LIBS Qt5::QWindowsIntegrationPlugin ${WINDOWS_EXTRA_LIBS} -lwinhttp -lcrypt32)

http://wald.intevation.org/projects/trustbridge/