diff tests/CMakeLists.txt @ 7:992c0ec57660

Add unit tests make CertificateList work.
author Andre Heinecke <aheinecke@intevation.de>
date Wed, 12 Feb 2014 16:52:27 +0000
parents
children f4f957c58e0a
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/tests/CMakeLists.txt	Wed Feb 12 16:52:27 2014 +0000
@@ -0,0 +1,19 @@
+set(EXECUTABLE_OUTPUT_PATH ${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/../ui)
+
+find_package(Qt5Test)
+
+macro(add_m13_test _source)
+  set(_test ${_source})
+  get_filename_component(_name ${_source} NAME_WE)
+  add_executable(${_name} ${_test} ${M13UI_SOURCES})
+  add_test(m13-${_name} ${_name})
+  target_link_libraries(${_name} Qt5::Test Qt5::Widgets ${EXTRA_STATIC_LIBS})
+endmacro()
+
+# Add the current source dir to the definition
+# so that it can be used in file names in the tests.
+add_definitions(-DSOURCE_DIR="${CMAKE_CURRENT_SOURCE_DIR}")
+add_m13_test(certlistparsertest.cpp)
+

http://wald.intevation.org/projects/trustbridge/