diff CMakeLists.txt @ 933:af27328bea9d

(issue89) Add sphinx integration for the build system.
author Andre Heinecke <andre.heinecke@intevation.de>
date Fri, 22 Aug 2014 17:06:56 +0200
parents dcb6ed6ad594
children e33a061977c8
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Aug 22 16:20:25 2014 +0200
+++ b/CMakeLists.txt	Fri Aug 22 17:06:56 2014 +0200
@@ -132,6 +132,14 @@
 configure_file (doc/Doxyfile.in doc/Doxyfile)
 add_subdirectory(doc)
 
+find_package(Sphinx)
+
+if (NOT SPHINX_FOUND)
+   message (STATUS "WARNING could not find sphinx (Package python-sphinx). Manuals will not be built.")
+else()
+   add_subdirectory(manuals)
+endif()
+
 # Configure packaging script for testing
 configure_file (packaging/win-createpackage.sh.in packaging/win-createpackage.sh @ONLY)
 configure_file (packaging/create-dist-package.sh.in packaging/create-dist-package.sh @ONLY)

http://wald.intevation.org/projects/trustbridge/