diff ui/CMakeLists.txt @ 407:af53c40e74b1

Rename m13ui to TrustBridge
author Andre Heinecke <aheinecke@intevation.de>
date Wed, 16 Apr 2014 13:38:11 +0000
parents 35d6b371ba63
children ac9e95ef6966
line wrap: on
line diff
--- a/ui/CMakeLists.txt	Wed Apr 16 13:31:16 2014 +0000
+++ b/ui/CMakeLists.txt	Wed Apr 16 13:38:11 2014 +0000
@@ -20,7 +20,7 @@
     ${CMAKE_CURRENT_SOURCE_DIR}/sslconnection.cpp
 )
 
-set(M13UI_SOURCES
+set(TRUSTBRIDGE_SOURCES
     ${CMAKE_CURRENT_SOURCE_DIR}/mainwindow.cpp
     ${CMAKE_CURRENT_SOURCE_DIR}/main.cpp
     ${CMAKE_CURRENT_SOURCE_DIR}/helpdialog.cpp
@@ -44,7 +44,7 @@
 )
 
 # Seperated to make it easier to include the sources in tests
-set(M13UI_RESOURCES
+set(TRUSTBRIDGE_RESOURCES
    ${CMAKE_CURRENT_SOURCE_DIR}/icons.qrc
    ${CMAKE_CURRENT_SOURCE_DIR}/certs.qrc
 )
@@ -91,16 +91,16 @@
 
 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS}")
 
-generate_cppcheck(SOURCES ${CINST_SOURCES} ${M13UI_SOURCES} TARGET_NAME m13_cppcheck)
+generate_cppcheck(SOURCES ${CINST_SOURCES} ${TRUSTBRIDGE_SOURCES} TARGET_NAME m13_cppcheck)
 add_dependencies(static_check m13_cppcheck)
 
 # Adding resources here in an extra variable to enable reuse of
-# M13UI_SOURCES in the test subdirectory.
-set(M13UI_SOURCES_WITH_RESOURCES ${M13UI_SOURCES})
-qt5_add_resources(M13UI_SOURCES_WITH_RESOURCES ${M13UI_RESOURCES})
-add_executable(m13ui ${M13UI_SOURCES_WITH_RESOURCES})
+# TRUSTBRIDGE_SOURCES in the test subdirectory.
+set(TRUSTBRIDGE_SOURCES_WITH_RESOURCES ${TRUSTBRIDGE_SOURCES})
+qt5_add_resources(TRUSTBRIDGE_SOURCES_WITH_RESOURCES ${TRUSTBRIDGE_RESOURCES})
+add_executable(trustbridge ${TRUSTBRIDGE_SOURCES_WITH_RESOURCES})
 
-target_link_libraries(m13ui Qt5::Widgets
+target_link_libraries(trustbridge Qt5::Widgets
    m13_common
    ${POLARSSL_LIBRARIES}
    ${EXTRA_STATIC_LIBS}
@@ -119,5 +119,5 @@
 # Tests
 add_subdirectory(tests)
 
-install(TARGETS m13ui DESTINATION bin)
+install(TARGETS trustbridge DESTINATION bin)
 install(TARGETS administrator DESTINATION bin)

http://wald.intevation.org/projects/trustbridge/