diff ui/CMakeLists.txt @ 910:eaed02defe6a

More SSLConnection refactoring. Fixes curl downloader.
author Andre Heinecke <andre.heinecke@intevation.de>
date Mon, 18 Aug 2014 18:51:33 +0200
parents d1c951b3012d
children 68db3a46ae36
line wrap: on
line diff
--- a/ui/CMakeLists.txt	Thu Aug 14 11:24:13 2014 +0200
+++ b/ui/CMakeLists.txt	Mon Aug 18 18:51:33 2014 +0200
@@ -26,11 +26,13 @@
     ${CMAKE_CURRENT_SOURCE_DIR}/sslhelp.cpp
 )
 
-if (${CURL_FOUND})
+if (${CURL_FOUND} AND ${USE_CURL})
    set(UICOMMON_SOURCES ${UICOMMON_SOURCES} ${CMAKE_CURRENT_SOURCE_DIR}/sslconnection_curl.cpp)
    add_definitions(-DUSE_CURL)
+elseif (${USE_CURL})
+   MESSAGE(FATAL_ERROR "libcurl not found but usage of curl is requested.")
 else()
-   MESSAGE(STATUS "Warning curl not found only bare polarssl ssl will be supported.")
+   MESSAGE(FATAL_ERROR "${CURL_FOUND} ${USE_CURL}")
 endif()
 
 # Cmake does not correctly identify gcc windres when cross compiling

http://wald.intevation.org/projects/trustbridge/