diff ui/tests/CMakeLists.txt @ 304:eecc06f714fd

Add first nsstest.
author Andre Heinecke <andre.heinecke@intevation.de>
date Thu, 03 Apr 2014 14:29:49 +0200
parents 56507c3d5f1e
children 4a3febc6d806
line wrap: on
line diff
--- a/ui/tests/CMakeLists.txt	Thu Apr 03 14:28:58 2014 +0200
+++ b/ui/tests/CMakeLists.txt	Thu Apr 03 14:29:49 2014 +0200
@@ -1,6 +1,9 @@
 set(EXECUTABLE_OUTPUT_PATH ${CMAKE_CURRENT_BINARY_DIR})
 
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/.. ${CMAKE_CURRENT_SOURCE_DIR}/../../common)
+include_directories(${CMAKE_CURRENT_BINARY_DIR}
+   ${CMAKE_SOURCE_DIR}/ui
+   ${CMAKE_SOURCE_DIR}/common
+   ${CMAKE_SOURCE_DIR}/cinst)
 
 find_package(Qt5Test)
 include_directories(${Qt5Test_INCLUDE_DIRS})
@@ -47,5 +50,7 @@
    add_m13_test(windowsstoretest.cpp "${CERTIFICATELIST_SOURCES};${CMAKE_SOURCE_DIR}/cinst/windowsstore.c")
 endif (WIN32)
 
+add_m13_test(nsstest.cpp "${CERTIFICATELIST_SOURCES};${CMAKE_SOURCE_DIR}/cinst/nssstore_linux.c")
+
 #add_m13_test(${CMAKE_SOURCE_DIR}/ui/main.cpp "${M13UI_SOURCES}")
 

http://wald.intevation.org/projects/trustbridge/