diff tests/CMakeLists.txt @ 18:f4f957c58e0a

Move listuitol and add cert pinning with a test certificate
author Andre Heinecke <aheinecke@intevation.de>
date Wed, 19 Feb 2014 15:41:14 +0000
parents 992c0ec57660
children dc1e1e9e62ce
line wrap: on
line diff
--- a/tests/CMakeLists.txt	Wed Feb 19 14:22:26 2014 +0000
+++ b/tests/CMakeLists.txt	Wed Feb 19 15:41:14 2014 +0000
@@ -4,10 +4,10 @@
 
 find_package(Qt5Test)
 
-macro(add_m13_test _source)
+macro(add_m13_test _source _additional_sources)
   set(_test ${_source})
   get_filename_component(_name ${_source} NAME_WE)
-  add_executable(${_name} ${_test} ${M13UI_SOURCES})
+  add_executable(${_name} ${_test} ${_additional_sources})
   add_test(m13-${_name} ${_name})
   target_link_libraries(${_name} Qt5::Test Qt5::Widgets ${EXTRA_STATIC_LIBS})
 endmacro()
@@ -15,5 +15,5 @@
 # Add the current source dir to the definition
 # so that it can be used in file names in the tests.
 add_definitions(-DSOURCE_DIR="${CMAKE_CURRENT_SOURCE_DIR}")
-add_m13_test(certlistparsertest.cpp)
+add_m13_test(certlistparsertest.cpp "${CMAKE_SOURCE_DIR}/cinst/listutil.c;${CMAKE_SOURCE_DIR}/ui/certificatelist.cpp")
 

http://wald.intevation.org/projects/trustbridge/